FAQFAQ    Board RulesBoard Rules    SearchSearch    LotteryLottery    RouletteRoulette    UsergroupsUsergroups
     RegisterRegister  ProfileProfile    Log in to check your private messagesLog in to check your private messages    Shop    Log inLog in 
View posts since last visit View your posts View unanswered posts

Objects not inserting in MWE

 
Post new topic   Reply to topic    Mafiascene.com Forum Index -> Ask a Modder - Tools
View previous topic :: View next topic  
Author Message
SooperK

Junior Member
Junior Member


Joined: 10 Nov 2014
Posts: 29
Location: Jennewa, Airdenor
41 Bank Notes
Items

PostPosted: Fri May 25, 2018 2:06 am    Post subject: Objects not inserting in MWE Reply with quote

Just got back into modding once more and maybe I am forgetting something simple. When I insert a human in Bscript and give a model and behavior and add some script and a name I save the file and exit out and open the World Editor. However, the object (human in this case) never appears anywhere in the Editor. Even when I search the name through the frames, it pulls up nothing. I remember when I modded before the human or car would appear just above the camera when the freeride file was opened in the editor. Thanks for any help.
Back to top
View user's profile Send private message
ASM.

Mafiascene Veteran Modder
Mafiascene Veteran Modder


Joined: 10 Jan 2014
Posts: 178

387 Bank Notes
Items

PostPosted: Fri May 25, 2018 9:31 pm    Post subject: Objects not inserting in MWE Reply with quote

Can you find that actor again if you reopen the mission with BScriptView? Does MWE spit out any warnings when you load the mission?
Back to top
View user's profile Send private message
mammix

Junior Member
Junior Member


Joined: 20 Sep 2014
Posts: 36
Location: Lublin, Poland
614 Bank Notes
Items

PostPosted: Fri May 25, 2018 10:04 pm    Post subject: Objects not inserting in MWE Reply with quote

Did you try to put the exact name in MWE? (Tools window, the bar under "List backdrop sector"). Maybe you put unexisting models and you just can't see them?
Good luck Wink
Back to top
View user's profile Send private message
SooperK

Junior Member
Junior Member


Joined: 10 Nov 2014
Posts: 29
Location: Jennewa, Airdenor
41 Bank Notes
Items

PostPosted: Sat May 26, 2018 1:47 am    Post subject: Objects not inserting in MWE Reply with quote

Yes, the actor still pulls up after I save in Bscript and reopen it; it saves the name, behavior and script. MWE shows nothing in any of the frames.. Also, I created a model human in MWE and gave a name, and when I open Bscript, the name of the model I created doesnt show either. And no, the MWE is not giving me any issues or warnings when I open a mission. What I am trying to do is insert some snipers around freeride day (using the script from the snipers in freeride extreme), but I am just confounded on why nothing is getting inserted into MWE and not even pulling up anything from Bscript.

***SOLVED*** silly mistake! I was not running Bscript as the admin. Ran as admin, inserted human, went into editor, and as normal was floating above the camera. However, none of these changes are showing up in the game Thinking
Back to top
View user's profile Send private message
mammix

Junior Member
Junior Member


Joined: 20 Sep 2014
Posts: 36
Location: Lublin, Poland
614 Bank Notes
Items

PostPosted: Sat May 26, 2018 10:41 am    Post subject: Objects not inserting in MWE Reply with quote

Are you loading from a save or restarting the mission? If I just load from a save, sometimes the newly inserted things don't show up.
Back to top
View user's profile Send private message
ASM.

Mafiascene Veteran Modder
Mafiascene Veteran Modder


Joined: 10 Jan 2014
Posts: 178

387 Bank Notes
Items

PostPosted: Sat May 26, 2018 1:01 pm    Post subject: Re: Objects not inserting in MWE Reply with quote

SooperK wrote:

***SOLVED*** silly mistake! I was not running Bscript as the admin. Ran as admin, inserted human, went into editor, and as normal was floating above the camera. However, none of these changes are showing up in the game Thinking

That's interesting. It's just speculation on my end but depending on where you've installed Mafia it's possible that you've fallen victim to file system virtualization. BScriptView most likely does not have an embedded application manifest so if it tries to write to some directory in, say, C:\Program Files (x86) as non-admin, Windows Vista+ will redirect the write to C:\Users\<your_account>\AppData\Local\VirtualStore. MWE on the other does have such a manifest and is hence not affected by this virtualization. That would explain why both tools see different versions of the same file. However I'm not sure whether this also explains why you're not seeing your changes in-game. Thinking

Do you have any Mafia mission files (such as scene2.bin) in that redirection target path I outlined above?
Back to top
View user's profile Send private message
SooperK

Junior Member
Junior Member


Joined: 10 Nov 2014
Posts: 29
Location: Jennewa, Airdenor
41 Bank Notes
Items

PostPosted: Sat May 26, 2018 8:02 pm    Post subject: Objects not inserting in MWE Reply with quote

There is a Mafia folder showing up in (x86), but it is saying that it is empty. Last night I kept messing around with trying to figure everything out and it was again the admin problem. On my old computer I had everything to run as admin every time I clicked on it and now I have a new computer, so I was forgetting that I had to manually run the programs as the admin. Simple as that fortunately. Nothing was saving otherwise, and also I noticed that the mission files had a lock symbol over them, so I suppose that is what was keeping me from altering any of their info. Running as admin took away that problem. And I was actually thinking the same thing at first that maybe both of the programs were not getting their information from the same source (and I would have had no idea how to fix that), but if it ever happens again (as I have to install Mafia at least once a month for modding) I will try that and see if it works. Thanks so much for the help. Cool shades
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Mafiascene.com Forum Index -> Ask a Modder - Tools All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

Generation Time: 0.028 | Queries: 19