FAQFAQ    Board RulesBoard Rules    SearchSearch    LotteryLottery    RouletteRoulette    UsergroupsUsergroups
     RegisterRegister  ProfileProfile    Log in to check your private messagesLog in to check your private messages    Shop    Log inLog in 
View posts since last visit View your posts View unanswered posts

stream_play problem

 
Post new topic   Reply to topic    Mafiascene.com Forum Index -> Ask a Modder - Modding
View previous topic :: View next topic  
Author Message
IDLH

New Member
New Member


Joined: 07 Sep 2014
Posts: 1

5 Bank Notes
Items

PostPosted: Thu Oct 02, 2014 11:45 am    Post subject: stream_play problem Reply with quote

Hi.
I wrote a code and it don't work Very happy
In theory it should change songs when used.
But after 1st click it does nothing, 2nd click activates stream_create 1 and next clicks do nothing.

Code:

dim_flt 2

stream_create 1, "sounds\music\01 - Main Theme.ogg"
stream_create 2, "sounds\music\city_music_01.ogg"
stream_create 3, "sounds\music\city_music_02.ogg"
stream_create 4, "sounds\music\city_music_03.ogg"
stream_create 5, "sounds\music\city_music_04.ogg"
stream_create 6, "sounds\music\city_music_05.ogg"
stream_create 7, "sounds\music\city_music_06.ogg"
stream_create 8, "sounds\music\city_music_07.ogg"
stream_create 9, "sounds\music\city_music_08.ogg"
stream_create 10, "sounds\music\city_music_09.ogg"
stream_create 11, "sounds\music\city_music_10.ogg"
stream_create 12, "sounds\music\city_music_11.ogg"
stream_create 13, "sounds\music\city_music_12.ogg"
stream_create 14, "sounds\music\city_music_13.ogg"
stream_create 15, "sounds\music\city_music_14.ogg"
stream_create 16, "sounds\music\city_music_15.ogg"

let flt[0]=0
let flt[1]=1

label 1337
detector_waitforuse
stream_stop flt[0]
stream_play flt[1]
stream_setloop flt[1], 1

let flt[0] = flt[0]+1
let flt[1] = flt[1]+1
goto 1337
Back to top
View user's profile Send private message
Jorns

Mafiascene Veteran Modder
Mafiascene Veteran Modder


Joined: 17 Jan 2014
Posts: 49

117 Bank Notes
Items

PostPosted: Thu Oct 02, 2014 12:14 pm    Post subject: stream_play problem Reply with quote

if you have a object you must click on them.If you use waitforuse command. The nex step of stream_create is the flt variable. Any stream_create XX uses a variable. You script uses a 17 variables. Try to change the dim_flt registrer to dim_flt 17.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Mafiascene.com Forum Index -> Ask a Modder - Modding All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

Generation Time: 0.018 | Queries: 18